# URI Credential Leakage Bypass over CVE-2025-27221

Advisory record · `GHSA-j4pr-3wm6-xx2r`

- **Identifiers:** `GHSA-j4pr-3wm6-xx2r` · `CVE-2025-61594`
- **State:** Confirmed
- **Severity:** CVSS 2.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-212](https://cwe.mitre.org/data/definitions/212.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-212](https://agentprime.io/advisories/tag/cwe-212.md)
- **Published:** 30 Dec 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Dec 2025, 21:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `uri` (RubyGems): affected `<0.12.5 || >=0.13.0, <0.13.3 || >=1.0.0, <1.0.4`; fixed in `0.12.5`, `0.13.3`, `1.0.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.1 Low, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0056, the 46th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-j4pr-3wm6-xx2r)

## Sources

- [GitHub Advisory Database: GHSA-j4pr-3wm6-xx2r](https://github.com/advisories/GHSA-j4pr-3wm6-xx2r)
- [OSV: GHSA-j4pr-3wm6-xx2r](https://osv.dev/vulnerability/GHSA-j4pr-3wm6-xx2r)
- <https://github.com/ruby/uri/security/advisories/GHSA-j4pr-3wm6-xx2r>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-61594>
- <https://github.com/ruby/uri/commit/20157e3e29b125ff41f1d9662e2e3b1d066f5902>
- <https://github.com/ruby/uri/commit/7e521b2da0833d964aab43019e735aea674e1c2c>
- <https://github.com/ruby/uri/commit/d3116ca66a3b1c97dc7577f9d2d6e353f391cd6a>
- <https://hackerone.com/reports/2957667>
- <https://github.com/advisories/GHSA-22h5-pq3x-2gf2>
- <https://github.com/ruby/uri>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/uri/CVE-2025-61594.yml>
- <https://www.ruby-lang.org/en/news/2025/02/26/security-advisories>
- <https://www.ruby-lang.org/en/news/2025/10/07/uri-cve-2025-61594>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-j4pr-3wm6-xx2r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-j4pr-3wm6-xx2r/>. Everything for agents: <https://agentprime.io/llms.txt>.
