# Apache Airflow's Backfill API authorized a request against a Dag id supplied by the caller whenever the \`backfill_id\` path segment failed to parse. The authorization dependency parsed it with \`int(...

Advisory record · `GHSA-j4jc-cq9h-xrhr`

- **Identifiers:** `GHSA-j4jc-cq9h-xrhr` · `BIT-airflow-2026-68968` · `CVE-2026-68968` · `PYSEC-2026-3710`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-436](https://cwe.mitre.org/data/definitions/436.html)
- **Tags:** [CWE-436](https://agentprime.io/advisories/tag/cwe-436.md)
- **Published:** 12 Aug 2026
- **Updated:** 15 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Aug 2026, 16:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `apache-airflow` (PyPI): affected `<3.3.1`; fixed in `3.3.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Airflow versions before 3.3.1 are vulnerable in the Backfill API, where the authorization check and the route handler parsed the backfill id differently. An authenticated user with edit permission on any one Dag can read, pause and cancel backfills belonging to other Dags, including moving their queued runs to failed. Upgrade apache-airflow to 3.3.1 or later, which parses the backfill id consistently.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from OSV

- **CISA KEV:** Not listed.
- **EPSS:** 0.0042, the 36th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 12 Aug 2026, 15:27 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-68968)
- 12 Aug 2026, 16:17 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-68968)
- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2026-3710)

## Sources

- [GitHub Advisory Database: GHSA-j4jc-cq9h-xrhr](https://github.com/advisories/GHSA-j4jc-cq9h-xrhr)
- [OSV: GHSA-j4jc-cq9h-xrhr](https://osv.dev/vulnerability/GHSA-j4jc-cq9h-xrhr)
- <https://github.com/apache/airflow/pull/70889>
- <http://www.openwall.com/lists/oss-security/2026/08/12/12>
- <https://lists.apache.org/thread/f9zmw6xs5b4syhwzbl6fsxm4kf2632ol>
- <https://github.com/advisories/GHSA-j4jc-cq9h-xrhr>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-j4jc-cq9h-xrhr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-j4jc-cq9h-xrhr/>. Everything for agents: <https://agentprime.io/llms.txt>.
