# EC-CUBE vulnerable to authorization bypass

Advisory record · `GHSA-j2hg-w4p4-6rvm`

- **Identifiers:** `GHSA-j2hg-w4p4-6rvm` · `CVE-2014-0808` · `PKSA-6sn4-mzr6-ydmw`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-566](https://cwe.mitre.org/data/definitions/566.html) · [CWE-639](https://cwe.mitre.org/data/definitions/639.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-566](https://agentprime.io/advisories/tag/cwe-566.md)
- **Published:** 17 May 2022
- **Updated:** 11 Jun 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 May 2022, 04:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ec-cube/ec-cube` (Packagist): affected `>=2.11.0, <2.12.2`; fixed in `2.12.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> EC-CUBE versions 2.11.0 through 2.12.2 are vulnerable to an authorization bypass caused by a user-controlled key, and EC-Orange systems deployed before June 29, 2015 are also affected. An attacker who is a user of the shopping website can send a crafted HTTP request to obtain other users' information. Upgrade ec-cube/ec-cube to version 2.12.2.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.022, the 82nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:29 UTC: First seen by agentprime
- 31 Oct 2026, 14:29 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-j2hg-w4p4-6rvm)

## Sources

- [GitHub Advisory Database: GHSA-j2hg-w4p4-6rvm](https://github.com/advisories/GHSA-j2hg-w4p4-6rvm)
- [OSV: GHSA-j2hg-w4p4-6rvm](https://osv.dev/vulnerability/GHSA-j2hg-w4p4-6rvm)
- <https://nvd.nist.gov/vuln/detail/CVE-2014-0808>
- <https://github.com/EC-CUBE/ec-cube>
- <https://jvn.jp/en/jp/JVN15637138>
- <https://jvndb.jvn.jp/jvndb/JVNDB-2024-000054>
- <http://jvn.jp/en/jp/JVN51770585>
- <http://jvn.jp/en/jp/JVN51770585/index.html>
- <http://jvndb.jvn.jp/jvndb/JVNDB-2014-000006>
- <http://www.ec-cube.net/info/weakness/weakness.php?id=57>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-j2hg-w4p4-6rvm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-j2hg-w4p4-6rvm/>. Everything for agents: <https://agentprime.io/llms.txt>.
