# Sinatra vulnerable to Reliance on Untrusted Inputs in a Security Decision

Advisory record · `GHSA-hxx2-7vcw-mqr3`

- **Identifiers:** `GHSA-hxx2-7vcw-mqr3` · `CVE-2024-21510`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-807](https://cwe.mitre.org/data/definitions/807.html)
- **Tags:** [CWE-807](https://agentprime.io/advisories/tag/cwe-807.md)
- **Published:** 1 Nov 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Nov 2024, 06:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `sinatra` (RubyGems): affected `<4.1.0`; fixed in `4.1.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P`, from CNA (snyk)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0049, the 42nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hxx2-7vcw-mqr3)

## Sources

- [GitHub Advisory Database: GHSA-hxx2-7vcw-mqr3](https://github.com/advisories/GHSA-hxx2-7vcw-mqr3)
- [OSV: GHSA-hxx2-7vcw-mqr3](https://osv.dev/vulnerability/GHSA-hxx2-7vcw-mqr3)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-21510>
- <https://github.com/sinatra/sinatra/pull/2010>
- <https://github.com/advisories/GHSA-hxx2-7vcw-mqr3>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sinatra/CVE-2024-21510.yml>
- <https://github.com/sinatra/sinatra>
- <https://github.com/sinatra/sinatra/blob/b626e2d82c23b4fde0b51782fd32ca27ccde1d1a/lib/sinatra/base.rb#L319>
- <https://github.com/sinatra/sinatra/blob/b626e2d82c23b4fde0b51782fd32ca27ccde1d1a/lib/sinatra/base.rb#L323C1-L343C17>
- <https://github.com/sinatra/sinatra/blob/main/CHANGELOG.md#410--2024-11-18>
- <https://security.snyk.io/vuln/SNYK-RUBY-SINATRA-6483832>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hxx2-7vcw-mqr3>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hxx2-7vcw-mqr3/>. Everything for agents: <https://agentprime.io/llms.txt>.
