# Symfony2 improper IP based access control

Advisory record · `GHSA-hx53-jchx-cr52`

- **Identifiers:** `GHSA-hx53-jchx-cr52` · `PKSA-hx88-8gq9-rm71`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-291](https://cwe.mitre.org/data/definitions/291.html)
- **Tags:** [CWE-291](https://agentprime.io/advisories/tag/cwe-291.md)
- **Published:** 30 May 2024
- **Updated:** 5 Dec 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 May 2024, 12:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `symfony/symfony` (Packagist): affected `>=2.0.0, <2.0.19 || >=2.1.0, <2.1.4`; fixed in `2.0.19`, `2.1.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Symfony (symfony/symfony) versions from 2.0.0 before 2.0.19 and from 2.1.0 before 2.1.4 are affected. When trust proxy mode is enabled, the client IP returned by Request::getClientIp() can be spoofed, so applications that rely on it for IP-based access control can be bypassed. Upgrade to 2.0.19 or 2.1.4 or later. The source recommends using the new Request::setTrustedProxies() method with a list of trusted proxy addresses instead of Request::trustProxyData().

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:28 UTC: First seen by agentprime
- 31 Oct 2026, 14:28 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hx53-jchx-cr52)

## Sources

- [GitHub Advisory Database: GHSA-hx53-jchx-cr52](https://github.com/advisories/GHSA-hx53-jchx-cr52)
- [OSV: GHSA-hx53-jchx-cr52](https://osv.dev/vulnerability/GHSA-hx53-jchx-cr52)
- <https://github.com/symfony/symfony/commit/922c2015f61a7205180d423dce1f7365cc2d8460>
- <https://github.com/symfony/symfony/commit/9ce892cf4395e73b136e9b5cd1fae9e91995c93b>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/2012-11-29.yaml>
- <https://github.com/symfony/symfony>
- <https://symfony.com/blog/security-release-symfony-2-0-19-and-2-1-4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hx53-jchx-cr52>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hx53-jchx-cr52/>. Everything for agents: <https://agentprime.io/llms.txt>.
