# Special Element Injection in notebook

Advisory record · `GHSA-hwvq-6gjx-j797`

- **Identifiers:** `GHSA-hwvq-6gjx-j797` · `BIT-jupyter-base-notebook-2021-32798` · `BIT-jupyter-notebook-2021-32798` · `CVE-2021-32798` · `PYSEC-2021-118`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-75](https://cwe.mitre.org/data/definitions/75.html) · [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-80](https://cwe.mitre.org/data/definitions/80.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-75](https://agentprime.io/advisories/tag/cwe-75.md)
- **Published:** 23 Aug 2021
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Aug 2021, 19:40 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `notebook` (PyPI): affected `<5.7.11 || >=6.0.0, <6.4.1`; fixed in `5.7.11`, `6.4.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The notebook package versions before 5.7.11 and from 6.0.0 before 6.4.1 are vulnerable. An attacker can supply a crafted notebook that executes code when a user opens it, which the advisory describes as remote code execution requiring user action. Upgrade to notebook 5.7.11 or 6.4.1.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.021, the 81st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:37 UTC: First seen by agentprime
- 31 Oct 2026, 14:37 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hwvq-6gjx-j797)

## Sources

- [GitHub Advisory Database: GHSA-hwvq-6gjx-j797](https://github.com/advisories/GHSA-hwvq-6gjx-j797)
- [OSV: GHSA-hwvq-6gjx-j797](https://osv.dev/vulnerability/GHSA-hwvq-6gjx-j797)
- <https://github.com/jupyter/notebook/security/advisories/GHSA-hwvq-6gjx-j797>
- <https://nvd.nist.gov/vuln/detail/CVE-2021-32798>
- <https://github.com/jupyter/notebook/commit/79fc76e890a8ec42f73a3d009e44ef84c14ef0d5>
- <https://github.com/jupyter/notebook>
- <https://github.com/pypa/advisory-database/tree/main/vulns/notebook/PYSEC-2021-118.yaml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hwvq-6gjx-j797>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hwvq-6gjx-j797/>. Everything for agents: <https://agentprime.io/llms.txt>.
