# Pivotal RabbitMQ is vulnerable to a denial of service attack

Advisory record · `GHSA-hrfh-7j5f-8ccr`

- **Identifiers:** `GHSA-hrfh-7j5f-8ccr` · `CVE-2019-11287`
- **State:** Confirmed
- **Severity:** CVSS 4.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-134](https://cwe.mitre.org/data/definitions/134.html) · [CWE-400](https://cwe.mitre.org/data/definitions/400.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 24 May 2022
- **Updated:** 10 Dec 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 May 2022, 17:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `RabbitMQ` (Hex): affected `>=3.7.0, <3.7.21 || >=3.8.0, <3.8.1 || <1.16.7 || >=1.17.0, <1.17.4`; fixed in `3.7.21`, `3.8.1`, `1.16.7`, `1.17.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.5 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H`, from CNA (pivotal)

- **CISA KEV:** Not listed.
- **EPSS:** 0.044, the 91st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:25 UTC: First seen by agentprime
- 31 Oct 2026, 15:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hrfh-7j5f-8ccr)

## Sources

- [GitHub Advisory Database: GHSA-hrfh-7j5f-8ccr](https://github.com/advisories/GHSA-hrfh-7j5f-8ccr)
- [OSV: GHSA-hrfh-7j5f-8ccr](https://osv.dev/vulnerability/GHSA-hrfh-7j5f-8ccr)
- <https://nvd.nist.gov/vuln/detail/CVE-2019-11287>
- <https://access.redhat.com/errata/RHSA-2020:0078>
- <https://github.com/DrunkenShells/Disclosures/tree/master/CVE-2019-11287-DoS%20via%20Heap%20Overflow-RabbitMQ%20Web%20Management%20Plugin>
- <https://github.com/rabbitmq/rabbitmq-server>
- <https://lists.debian.org/debian-lts-announce/2021/07/msg00011.html>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/EEQ6O7PMNJKYFMQYHAB55L423GYK63SO>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PYTGR3D5FW2O25RXZOTIZMOD2HAUVBE4>
- <https://pivotal.io/security/cve-2019-11287>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hrfh-7j5f-8ccr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hrfh-7j5f-8ccr/>. Everything for agents: <https://agentprime.io/llms.txt>.
