# distribution catalog API endpoint can lead to OOM via malicious user input

Advisory record · `GHSA-hqxw-f8mx-cpmw`

- **Identifiers:** `GHSA-hqxw-f8mx-cpmw` · `CVE-2023-2253` · `GO-2023-1772`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-475](https://cwe.mitre.org/data/definitions/475.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-475](https://agentprime.io/advisories/tag/cwe-475.md)
- **Published:** 11 May 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 May 2023, 20:37 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/docker/distribution` (Go): affected `<2.8.2-beta.1`; fixed in `2.8.2-beta.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of github.com/docker/distribution before 2.8.2-beta.1 are vulnerable to denial of service through the /v2/\_catalog API endpoint. A remote attacker can send a request with an extremely large value for the record-count parameter, causing the server to allocate a very large slice and run out of memory, particularly on memory-restricted systems. Upgrade to 2.8.2-beta.1 or later; the source lists no workaround other than restricting access to the endpoint.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0094, the 61st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:15 UTC: First seen by agentprime
- 31 Oct 2026, 14:15 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hqxw-f8mx-cpmw)

## Sources

- [GitHub Advisory Database: GHSA-hqxw-f8mx-cpmw](https://github.com/advisories/GHSA-hqxw-f8mx-cpmw)
- [OSV: GHSA-hqxw-f8mx-cpmw](https://osv.dev/vulnerability/GHSA-hqxw-f8mx-cpmw)
- <https://github.com/distribution/distribution/security/advisories/GHSA-hqxw-f8mx-cpmw>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-2253>
- <https://github.com/distribution/distribution/commit/f55a6552b006a381d9167e328808565dd2bf77dc>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2189886>
- <https://github.com/distribution/distribution>
- <https://lists.debian.org/debian-lts-announce/2023/06/msg00035.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hqxw-f8mx-cpmw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hqxw-f8mx-cpmw/>. Everything for agents: <https://agentprime.io/llms.txt>.
