# SQL Injection Vulnerability via ActiveRecord comments

Advisory record · `GHSA-hq7p-j377-6v63`

- **Identifiers:** `GHSA-hq7p-j377-6v63` · `CVE-2023-22794`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-89](https://cwe.mitre.org/data/definitions/89.html)
- **Tags:** [SQL injection](https://agentprime.io/advisories/tag/sql-injection.md)
- **Published:** 18 Jan 2023
- **Updated:** 21 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Jan 2023, 18:20 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `activerecord` (RubyGems): affected `>=6.0.0, <6.0.6.1 || >=6.1.0, <6.1.7.1 || >=7.0.0, <7.0.4.1`; fixed in `6.0.6.1`, `6.1.7.1`, `7.0.4.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.022, the 82nd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 18 Jan 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-hq7p-j377-6v63](https://github.com/advisories/GHSA-hq7p-j377-6v63)
- [OSV: GHSA-hq7p-j377-6v63](https://osv.dev/vulnerability/GHSA-hq7p-j377-6v63)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-22794>
- <https://github.com/rails/rails/commit/d7aba06953f9fa789c411676b941d20df8ef73de>
- <https://discuss.rubyonrails.org/t/cve-2023-22794-sql-injection-vulnerability-via-activerecord-comments/82117>
- <https://github.com/rails/rails>
- <https://github.com/rails/rails/releases/tag/v7.0.4.1>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2023-22794.yml>
- <https://security.netapp.com/advisory/ntap-20240202-0008>
- <https://www.debian.org/security/2023/dsa-5372>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hq7p-j377-6v63>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hq7p-j377-6v63/>. Everything for agents: <https://agentprime.io/llms.txt>.
