# httparty Has Potential SSRF Vulnerability That Leads to API Key Leakage

Advisory record · `GHSA-hm5p-x4rq-38w4`

- **Identifiers:** `GHSA-hm5p-x4rq-38w4` · `CVE-2025-68696`
- **State:** Confirmed
- **Severity:** CVSS 7.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-918](https://cwe.mitre.org/data/definitions/918.html)
- **Tags:** [Server-side request forgery (SSRF)](https://agentprime.io/advisories/tag/ssrf.md)
- **Published:** 23 Dec 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Dec 2025, 19:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `httparty` (RubyGems): affected `<0.24.0`; fixed in `0.24.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.8 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0030, the 23rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hm5p-x4rq-38w4)

## Sources

- [GitHub Advisory Database: GHSA-hm5p-x4rq-38w4](https://github.com/advisories/GHSA-hm5p-x4rq-38w4)
- [OSV: GHSA-hm5p-x4rq-38w4](https://osv.dev/vulnerability/GHSA-hm5p-x4rq-38w4)
- <https://github.com/jnunemaker/httparty/security/advisories/GHSA-hm5p-x4rq-38w4>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-68696>
- <https://github.com/jnunemaker/httparty/commit/0529bcd6309c9fd9bfdd50ae211843b10054c240>
- <https://github.com/jnunemaker/httparty>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/httparty/CVE-2025-68696.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hm5p-x4rq-38w4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hm5p-x4rq-38w4/>. Everything for agents: <https://agentprime.io/llms.txt>.
