# Race Condition leading to logging errors

Advisory record · `GHSA-hjp3-5g2q-7jww`

- **Identifiers:** `GHSA-hjp3-5g2q-7jww` · `CVE-2024-22047`
- **State:** Confirmed
- **Severity:** CVSS 3.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-362](https://cwe.mitre.org/data/definitions/362.html)
- **Tags:** [Race condition](https://agentprime.io/advisories/tag/race-condition.md)
- **Published:** 1 May 2023
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 May 2023, 14:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `audited` (RubyGems): affected `>=4.0.0, <5.3.3`; fixed in `5.3.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.1 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0050, the 42nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 1 May 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-hjp3-5g2q-7jww](https://github.com/advisories/GHSA-hjp3-5g2q-7jww)
- [OSV: GHSA-hjp3-5g2q-7jww](https://osv.dev/vulnerability/GHSA-hjp3-5g2q-7jww)
- <https://github.com/collectiveidea/audited/security/advisories/GHSA-hjp3-5g2q-7jww>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-22047>
- <https://github.com/collectiveidea/audited/issues/601>
- <https://github.com/collectiveidea/audited/pull/669>
- <https://github.com/collectiveidea/audited/pull/671>
- <https://github.com/collectiveidea/audited/commit/342734c9396d8f96d3165f1d8531c626139fa4c6>
- <https://github.com/collectiveidea/audited>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/audited/CVE-2024-22047.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hjp3-5g2q-7jww>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hjp3-5g2q-7jww/>. Everything for agents: <https://agentprime.io/llms.txt>.
