# LiteLLM vulnerable to reflected XSS in /sso/debug/callback

Advisory record · `GHSA-hhww-mrg2-969h`

- **Identifiers:** `GHSA-hhww-mrg2-969h`
- **State:** Confirmed
- **Severity:** CVSS 6.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2026, 15:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `litellm` (PyPI): affected `>=1.65.5, <1.85.0`; fixed in `1.85.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> LiteLLM versions from 1.65.5 up to but not including 1.85.0 are vulnerable to reflected cross-site scripting through the /sso/debug/callback endpoint, which places identity-provider-supplied fields into an inline script block without HTML-safe escaping. An attacker who controls an account on the configured identity provider could craft a callback URL and get a logged-in proxy admin to open it, running script in the proxy's origin and potentially reading session cookies for admin access. The fix is to upgrade to LiteLLM 1.85.0.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hhww-mrg2-969h)

## Sources

- [GitHub Advisory Database: GHSA-hhww-mrg2-969h](https://github.com/advisories/GHSA-hhww-mrg2-969h)
- [OSV: GHSA-hhww-mrg2-969h](https://osv.dev/vulnerability/GHSA-hhww-mrg2-969h)
- <https://github.com/BerriAI/litellm/security/advisories/GHSA-hhww-mrg2-969h>
- <https://github.com/BerriAI/litellm/pull/27498>
- <https://github.com/BerriAI/litellm/commit/13a193367f0ae2e7e8b29913e0d23a32d3bb0457>
- <https://github.com/BerriAI/litellm>
- <https://github.com/BerriAI/litellm/releases/tag/v1.85.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hhww-mrg2-969h>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hhww-mrg2-969h/>. Everything for agents: <https://agentprime.io/llms.txt>.
