# sigstore has insufficient validation of integration timestamp during verification

Advisory record · `GHSA-hhfg-fwrw-87w7`

- **Identifiers:** `GHSA-hhfg-fwrw-87w7` · `CVE-2024-55655` · `PYSEC-2026-1923`
- **State:** Confirmed
- **Severity:** CVSS 2.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-325](https://cwe.mitre.org/data/definitions/325.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-325](https://agentprime.io/advisories/tag/cwe-325.md)
- **Published:** 11 Dec 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 Dec 2024, 18:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `sigstore` (PyPI): affected `>=2.0.0, <3.6.0`; fixed in `3.6.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of sigstore from 2.0.0 up to but not including 3.6.0 insufficiently validate the integration timestamp in v2 and v3 bundles during verification. The timestamp is only checked when a source of signed time, such as an inclusion promise, is present; otherwise it is trusted. An attacker who can modify a bundle could alter the timestamp, but the source reports the impact as low, mainly causing denial of service, since other checks still reject forged signatures. Upgrade to sigstore 3.6.0 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.7 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:35 UTC: First seen by agentprime
- 31 Oct 2026, 14:35 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hhfg-fwrw-87w7)

## Sources

- [GitHub Advisory Database: GHSA-hhfg-fwrw-87w7](https://github.com/advisories/GHSA-hhfg-fwrw-87w7)
- [OSV: GHSA-hhfg-fwrw-87w7](https://osv.dev/vulnerability/GHSA-hhfg-fwrw-87w7)
- <https://github.com/sigstore/sigstore-python/security/advisories/GHSA-hhfg-fwrw-87w7>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-55655>
- <https://github.com/sigstore/sigstore-python/commit/300b502ae99ebfaace124f1f4e422a6a669369cf>
- <https://github.com/sigstore/sigstore-python>
- <https://github.com/sigstore/sigstore-python/releases/tag/v3.6.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hhfg-fwrw-87w7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hhfg-fwrw-87w7/>. Everything for agents: <https://agentprime.io/llms.txt>.
