# @hono/node-server has Denial of Service risk when receiving Host header that cannot be parsed

Advisory record · `GHSA-hgxw-5xg3-69jx`

- **Identifiers:** `GHSA-hgxw-5xg3-69jx` · `CVE-2024-32652`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-755](https://cwe.mitre.org/data/definitions/755.html)
- **Tags:** [CWE-755](https://agentprime.io/advisories/tag/cwe-755.md)
- **Published:** 19 Apr 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 19 Apr 2024, 19:48 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@hono/node-server` (npm): affected `>=1.3.0, <1.10.1`; fixed in `1.10.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0088, the 59th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 19 Apr 2024. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-hgxw-5xg3-69jx](https://github.com/advisories/GHSA-hgxw-5xg3-69jx)
- [OSV: GHSA-hgxw-5xg3-69jx](https://osv.dev/vulnerability/GHSA-hgxw-5xg3-69jx)
- <https://github.com/honojs/node-server/security/advisories/GHSA-hgxw-5xg3-69jx>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-32652>
- <https://github.com/honojs/node-server/issues/159>
- <https://github.com/honojs/node-server/issues/161>
- <https://github.com/honojs/node-server/commit/306d98f02a8671a0a1fb91ac8fe7e281690c05af>
- <https://github.com/honojs/node-server/commit/d847e60249fd8183ba0998bc379ba20505643204>
- <https://github.com/honojs/node-server>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hgxw-5xg3-69jx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hgxw-5xg3-69jx/>. Everything for agents: <https://agentprime.io/llms.txt>.
