# Fiber panics when fiber.Ctx.BodyParser parses invalid range index

Advisory record · `GHSA-hg3g-gphw-5hhm`

- **Identifiers:** `GHSA-hg3g-gphw-5hhm` · `CVE-2025-48075` · `GO-2025-3706`
- **State:** Confirmed
- **Severity:** CVSS 7.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-129](https://cwe.mitre.org/data/definitions/129.html)
- **Tags:** [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 22 May 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 May 2025, 20:08 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/gofiber/fiber/v2` (Go): affected `>=2.52.6, <2.52.7`; fixed in `2.52.7`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Fiber (github.com/gofiber/fiber/v2) versions 2.52.6 up to but not including 2.52.7 panic when fiber.Ctx.BodyParser parses a struct with range values and receives a negative range index. An attacker who can send a crafted request body to an affected endpoint can crash the server, causing denial of service. Upgrade to Fiber 2.52.7. The source gives few details about other conditions.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0053, the 44th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hg3g-gphw-5hhm)

## Sources

- [GitHub Advisory Database: GHSA-hg3g-gphw-5hhm](https://github.com/advisories/GHSA-hg3g-gphw-5hhm)
- [OSV: GHSA-hg3g-gphw-5hhm](https://osv.dev/vulnerability/GHSA-hg3g-gphw-5hhm)
- <https://github.com/gofiber/fiber/security/advisories/GHSA-hg3g-gphw-5hhm>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-48075>
- <https://github.com/gofiber/fiber/commit/e115c08b8f059a4a031b492aa9eef0712411853d>
- <https://github.com/gofiber/fiber>
- <https://pkg.go.dev/vuln/GO-2025-3706>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hg3g-gphw-5hhm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hg3g-gphw-5hhm/>. Everything for agents: <https://agentprime.io/llms.txt>.
