# rubyipmi is vulnerable to OS Command Injection through malicious usernames

Advisory record · `GHSA-hfcp-477w-3wjw`

- **Identifiers:** `GHSA-hfcp-477w-3wjw` · `CVE-2026-0980`
- **State:** Confirmed
- **Severity:** CVSS 8.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-78](https://cwe.mitre.org/data/definitions/78.html)
- **Tags:** [Command injection](https://agentprime.io/advisories/tag/command-injection.md)
- **Published:** 27 Feb 2026
- **Updated:** 27 Mar 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Feb 2026, 09:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `rubyipmi` (RubyGems): affected `<0.13.0`; fixed in `0.13.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.3 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`, from CNA (redhat)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0085, the 58th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 27 Feb 2026, 07:30 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-0980)
- 27 Feb 2026, 08:17 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-0980)

## Sources

- [GitHub Advisory Database: GHSA-hfcp-477w-3wjw](https://github.com/advisories/GHSA-hfcp-477w-3wjw)
- [OSV: GHSA-hfcp-477w-3wjw](https://osv.dev/vulnerability/GHSA-hfcp-477w-3wjw)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-0980>
- <https://github.com/logicminds/rubyipmi/commit/252503a7b4dca68388165883b0322024e344a215>
- <https://access.redhat.com/errata/RHSA-2026:5968>
- <https://access.redhat.com/errata/RHSA-2026:5970>
- <https://access.redhat.com/errata/RHSA-2026:5971>
- <https://access.redhat.com/security/cve/CVE-2026-0980>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2429874>
- <https://github.com/logicminds/rubyipmi>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubyipmi/CVE-2026-0980.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hfcp-477w-3wjw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hfcp-477w-3wjw/>. Everything for agents: <https://agentprime.io/llms.txt>.
