# Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Exposure of Sensitive Information Through Metadata vulnerability

Advisory record · `GHSA-hf52-78x8-6w3w`

- **Identifiers:** `GHSA-hf52-78x8-6w3w` · `BIT-activemq-2026-49270` · `CVE-2026-49270`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-1230](https://cwe.mitre.org/data/definitions/1230.html)
- **Tags:** [CWE-1230](https://agentprime.io/advisories/tag/cwe-1230.md)
- **Published:** 1 Jun 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Jun 2026, 09:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.activemq:apache-activemq` (Maven): affected `<5.19.7 || >=6.0.0, <6.2.6`; fixed in `5.19.7`, `6.2.6`
- `org.apache.activemq:activemq-broker` (Maven): affected `<5.19.7 || >=6.0.0, <6.2.6`; fixed in `5.19.7`, `6.2.6`
- `org.apache.activemq:activemq-all` (Maven): affected `<5.19.7 || >=6.0.0, <6.2.6`; fixed in `5.19.7`, `6.2.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache ActiveMQ Broker, Apache ActiveMQ, and Apache ActiveMQ All are vulnerable before 5.19.7 and from 6.0.0 before 6.2.6. Brokers with a network connector that has syncDurableSubs set to true can be queried by an unauthenticated remote attacker, who can obtain a list of durable topic subscriptions, including client identifiers, subscription names, topic destinations, and JMS selector expressions. Upgrade to version 5.19.7 or 6.2.6.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0037, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:17 UTC: First seen by agentprime
- 31 Oct 2026, 14:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hf52-78x8-6w3w)

## Sources

- [GitHub Advisory Database: GHSA-hf52-78x8-6w3w](https://github.com/advisories/GHSA-hf52-78x8-6w3w)
- [OSV: GHSA-hf52-78x8-6w3w](https://osv.dev/vulnerability/GHSA-hf52-78x8-6w3w)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-49270>
- <https://github.com/apache/activemq>
- <https://lists.apache.org/thread/k3233c1x506z3w7x4z0dqvd86d4v2fr2>
- <http://www.openwall.com/lists/oss-security/2026/05/31/22>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hf52-78x8-6w3w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hf52-78x8-6w3w/>. Everything for agents: <https://agentprime.io/llms.txt>.
