# vLLM vulnerable to Denial of Service by abusing xgrammar cache

Advisory record · `GHSA-hf3c-wxg2-49q9`

- **Identifiers:** `GHSA-hf3c-wxg2-49q9`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-770](https://cwe.mitre.org/data/definitions/770.html) · [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 15 Apr 2025
- **Updated:** 15 Apr 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Apr 2025, 21:21 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `>=0.6.5, <0.8.4`; fixed in `0.8.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 15 Apr 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-hf3c-wxg2-49q9](https://github.com/advisories/GHSA-hf3c-wxg2-49q9)
- [OSV: GHSA-hf3c-wxg2-49q9](https://osv.dev/vulnerability/GHSA-hf3c-wxg2-49q9)
- <https://github.com/mlc-ai/xgrammar/security/advisories/GHSA-389x-67px-mjg3>
- <https://github.com/vllm-project/vllm/security/advisories/GHSA-hf3c-wxg2-49q9>
- <https://github.com/vllm-project/vllm/pull/16283>
- <https://github.com/vllm-project/vllm/commit/cb84e45ac75b42ba6795145923e8eb323bb825ad>
- <https://github.com/vllm-project/vllm>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hf3c-wxg2-49q9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hf3c-wxg2-49q9/>. Everything for agents: <https://agentprime.io/llms.txt>.
