# Incorrect Calculation in github.com/open-policy-agent/opa

Advisory record · `GHSA-hcw3-j74m-qc58`

- **Identifiers:** `GHSA-hcw3-j74m-qc58` · `CVE-2022-23628` · `GO-2022-0316`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-682](https://cwe.mitre.org/data/definitions/682.html)
- **Tags:** [CWE-682](https://agentprime.io/advisories/tag/cwe-682.md)
- **Published:** 9 Feb 2022
- **Updated:** 20 May 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Feb 2022, 22:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/open-policy-agent/opa` (Go): affected `>=0.33.1, <0.37.2`; fixed in `0.37.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.010, the 63rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 9 Feb 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-hcw3-j74m-qc58](https://github.com/advisories/GHSA-hcw3-j74m-qc58)
- [OSV: GHSA-hcw3-j74m-qc58](https://osv.dev/vulnerability/GHSA-hcw3-j74m-qc58)
- <https://github.com/open-policy-agent/opa/security/advisories/GHSA-hcw3-j74m-qc58>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-23628>
- <https://github.com/open-policy-agent/opa/pull/3851>
- <https://github.com/open-policy-agent/opa/commit/2bd8edab9e10e2dc9cf76ae8335ced0c224f3055>
- <https://github.com/open-policy-agent/opa/commit/932e4ffc37a590ace79e9b75ca4340288c220239>
- <https://github.com/open-policy-agent/opa/commit/bfd984ddf93ef2c4963a08d4fdadae0bcf1a3717>
- <https://github.com/open-policy-agent/opa>
- <https://pkg.go.dev/vuln/GO-2022-0316>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hcw3-j74m-qc58>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hcw3-j74m-qc58/>. Everything for agents: <https://agentprime.io/llms.txt>.
