# Gunicorn HTTP Request/Response Smuggling vulnerability

Advisory record · `GHSA-hc5x-x2vx-497g`

- **Identifiers:** `GHSA-hc5x-x2vx-497g` · `CVE-2024-6827` · `PYSEC-2026-1433`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 20 Mar 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Mar 2025, 12:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `gunicorn` (PyPI): affected `<22.0.0`; fixed in `22.0.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Gunicorn versions before 22.0.0 do not properly validate the Transfer-Encoding header, so requests can be handled using Content-Length instead, enabling TE.CL request smuggling. An attacker who can send HTTP requests through a proxy or front-end in front of Gunicorn could smuggle requests, which may enable cache poisoning, session manipulation, or security bypass. Upgrade to gunicorn 22.0.0 or later. The source gives few details on specific exploitation conditions.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (@huntr_ai)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0081, the 56th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:37 UTC: First seen by agentprime
- 31 Oct 2026, 14:37 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-hc5x-x2vx-497g)

## Sources

- [GitHub Advisory Database: GHSA-hc5x-x2vx-497g](https://github.com/advisories/GHSA-hc5x-x2vx-497g)
- [OSV: GHSA-hc5x-x2vx-497g](https://osv.dev/vulnerability/GHSA-hc5x-x2vx-497g)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-6827>
- <https://github.com/benoitc/gunicorn/issues/3087>
- <https://github.com/benoitc/gunicorn/issues/3278>
- <https://github.com/benoitc/gunicorn/pull/3113>
- <https://github.com/benoitc/gunicorn>
- <https://github.com/benoitc/gunicorn/releases/tag/22.0.0>
- <https://huntr.com/bounties/1b4f8f38-39da-44b6-9f98-f618639d0dd7>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-hc5x-x2vx-497g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-hc5x-x2vx-497g/>. Everything for agents: <https://agentprime.io/llms.txt>.
