# Apache Tomcat's rewrite valve has an Always-Incorrect Control Flow Implementation vulnerability

Advisory record · `GHSA-h792-v28v-ppgr`

- **Identifiers:** `GHSA-h792-v28v-ppgr` · `BIT-tomcat-2026-53404` · `CVE-2026-53404`
- **State:** Confirmed
- **Severity:** CVSS 7.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-670](https://cwe.mitre.org/data/definitions/670.html)
- **Tags:** [CWE-670](https://agentprime.io/advisories/tag/cwe-670.md)
- **Published:** 29 Jun 2026
- **Updated:** 4 Nov 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Jun 2026, 21:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.tomcat.embed:tomcat-embed-core` (Maven): affected `>=11.0.0-M1, <11.0.23 || >=10.1.0-M1, <10.1.56 || >=9.0.0.M1, <9.0.119 || >=8.5.0, <=8.5.100`; fixed in `11.0.23`, `10.1.56`, `9.0.119`
- `org.apache.tomcat:tomcat` (Maven): affected `>=11.0.0-M1, <11.0.23 || >=10.1.0-M1, <10.1.56 || >=9.0.0.M1, <9.0.119 || >=8.5.0, <=8.5.100`; fixed in `11.0.23`, `10.1.56`, `9.0.119`
- `org.apache.tomcat:tomcat-catalina` (Maven): affected `>=11.0.0-M1, <11.0.23 || >=10.1.0-M1, <10.1.56 || >=9.0.0.M1, <9.0.119 || >=8.5.0, <=8.5.100`; fixed in `11.0.23`, `10.1.56`, `9.0.119`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.3 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0065, the 51st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 29 Jun 2026, 21:32 UTC: [Confirmed by GitHub Advisory Database](https://github.com/advisories/GHSA-h792-v28v-ppgr)
- 4 Nov 2026, 17:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-h792-v28v-ppgr)

## Sources

- [GitHub Advisory Database: GHSA-h792-v28v-ppgr](https://github.com/advisories/GHSA-h792-v28v-ppgr)
- [OSV: GHSA-h792-v28v-ppgr](https://osv.dev/vulnerability/GHSA-h792-v28v-ppgr)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-53404>
- <https://github.com/apache/tomcat/commit/b647cb584cea8bf95e64f5d2526c59ab8fca3225>
- <https://github.com/apache/tomcat/commit/bbb6219fa5ac185060bef7842cee5fb90230ca00>
- <https://github.com/apache/tomcat/commit/fe06ae8a71997061596f54189dae1b1b5da75430>
- <https://github.com/apache/tomcat>
- <https://lists.apache.org/thread/rdhpghgfskrdmw9hqzjgjrtw538smpmz>
- <https://tomcat.apache.org/security-10.html>
- <https://tomcat.apache.org/security-11.html>
- <https://tomcat.apache.org/security-9.html>
- <http://www.openwall.com/lists/oss-security/2026/06/29/21>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-h792-v28v-ppgr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-h792-v28v-ppgr/>. Everything for agents: <https://agentprime.io/llms.txt>.
