# next.js cache leak across root param values in nested 'use cache' functions

Advisory record · `GHSA-h694-7cp9-m8p3`

- **Identifiers:** `GHSA-h694-7cp9-m8p3` · `CVE-2026-103004`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-524](https://cwe.mitre.org/data/definitions/524.html)
- **Tags:** [CWE-524](https://agentprime.io/advisories/tag/cwe-524.md)
- **Published:** 22 Oct 2026
- **Updated:** 22 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Oct 2026, 16:08 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `next` (npm): affected `>=16.3.0, <16.3.8`; fixed in `16.3.8`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Next.js versions from 16.3.0 before 16.3.8 are affected when Cache Components is enabled and a 'use cache' function calls another 'use cache' function that reads a root param. The enclosing function's cache key can omit that root param, so one cached entry may be served for different root param values, and downstream caches may spread it further. An attacker cannot choose which values leak, and the source does not say what network access or account is needed. Upgrade next to version 16.3.8, which is the fixed release; the source lists no workarounds.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-h694-7cp9-m8p3)

## Sources

- [GitHub Advisory Database: GHSA-h694-7cp9-m8p3](https://github.com/advisories/GHSA-h694-7cp9-m8p3)
- [OSV: GHSA-h694-7cp9-m8p3](https://osv.dev/vulnerability/GHSA-h694-7cp9-m8p3)
- <https://github.com/vercel/next.js/security/advisories/GHSA-h694-7cp9-m8p3>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-103004>
- <https://github.com/vercel/next.js/commit/e92db4536a7f34ae2dbda583cfa1b4e0d06d1865>
- <https://github.com/vercel/next.js>
- <https://github.com/vercel/next.js/releases/tag/v16.3.8>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-h694-7cp9-m8p3>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-h694-7cp9-m8p3/>. Everything for agents: <https://agentprime.io/llms.txt>.
