# Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI whic...

Advisory record · `GHSA-h574-6646-vfxx`

- **Identifiers:** `GHSA-h574-6646-vfxx` · `BIT-airflow-2024-28746` · `CVE-2024-28746` · `PYSEC-2024-46`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-281](https://cwe.mitre.org/data/definitions/281.html)
- **Tags:** [CWE-281](https://agentprime.io/advisories/tag/cwe-281.md)
- **Published:** 14 Mar 2024
- **Updated:** 10 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Mar 2024, 09:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `apache-airflow` (PyPI): affected `>=2.8.0, <2.8.3rc1`; fixed in `2.8.3rc1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`, from ADP (CISA-ADP)

- **CISA KEV:** Not listed.
- **EPSS:** 0.013, the 71st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 14 Mar 2024. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-h574-6646-vfxx](https://github.com/advisories/GHSA-h574-6646-vfxx)
- [OSV: GHSA-h574-6646-vfxx](https://osv.dev/vulnerability/GHSA-h574-6646-vfxx)
- <https://github.com/apache/airflow/pull/37881>
- <https://lists.apache.org/thread/b4pffc7w7do6qgk4jjbyxvdz5odrvny7>
- <https://github.com/advisories/GHSA-h574-6646-vfxx>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-h574-6646-vfxx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-h574-6646-vfxx/>. Everything for agents: <https://agentprime.io/llms.txt>.
