# Duplicate Advisory: python-jose denial of service via compressed JWE content

Advisory record · `GHSA-h4pw-wxh7-4vjj` · Withdrawn

- **Identifiers:** `GHSA-h4pw-wxh7-4vjj` · `CVE-2024-29370` · `PYSEC-2025-185`
- **State:** Withdrawn
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-409](https://cwe.mitre.org/data/definitions/409.html)
- **Tags:** [CWE-409](https://agentprime.io/advisories/tag/cwe-409.md)
- **Published:** 17 Dec 2025
- **Updated:** 10 Jun 2026
- **Reviewed by a person:** No

**Withdrawn.** The GitHub Advisory Database withdrew this advisory on 18 Dec 2025. The record stays here, marked withdrawn.

Published by the GitHub Advisory Database at 17 Dec 2025, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `python-jose` (PyPI): affected `<3.4.0`; fixed in `3.4.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0019, the 8th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 17 Dec 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-h4pw-wxh7-4vjj](https://github.com/advisories/GHSA-h4pw-wxh7-4vjj)
- [OSV: GHSA-h4pw-wxh7-4vjj](https://osv.dev/vulnerability/GHSA-h4pw-wxh7-4vjj)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-29370>
- <https://github.com/mpdavis/python-jose/issues/344>
- <https://github.com/mpdavis/python-jose/commit/483529ee93a3ab510ab579d4d4cc644dba926ade>
- <https://github.com/mpdavis/python-jose/releases/tag/3.4.0>
- <https://github.com/pypa/advisory-database/tree/main/vulns/python-jose/PYSEC-2025-185.yaml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-h4pw-wxh7-4vjj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-h4pw-wxh7-4vjj/>. Everything for agents: <https://agentprime.io/llms.txt>.
