# Mautic does not shield .env files from web traffic

Advisory record · `GHSA-h2wg-v8wg-jhxh`

- **Identifiers:** `GHSA-h2wg-v8wg-jhxh` · `CVE-2024-47056` · `PKSA-x5tz-t44g-gk96`
- **State:** Confirmed
- **Severity:** CVSS 5.1 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-312](https://cwe.mitre.org/data/definitions/312.html) · [CWE-526](https://cwe.mitre.org/data/definitions/526.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-526](https://agentprime.io/advisories/tag/cwe-526.md)
- **Published:** 28 May 2025
- **Updated:** 28 May 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 May 2025, 17:38 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `mautic/core` (Packagist): affected `>=4.4.0, <4.4.16 || >=5.0.0-alpha, <5.2.6 || >=6.0.0-alpha, <6.0.2`; fixed in `4.4.16`, `5.2.6`, `6.0.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Mautic (mautic/core) versions from 4.4.0 before 4.4.16, from 5.0.0-alpha before 5.2.6, and from 6.0.0-alpha before 6.0.2 are affected. Because the web server does not block access to .env files, an unauthenticated remote attacker can view their contents by requesting the file's URL, which may expose database credentials, API keys and other system configuration. Upgrade to 4.4.16, 5.2.6, 6.0.2 or later. If you cannot upgrade, Nginx users should add a configuration block that denies access to .env files, and Apache users should confirm the server honours .htaccess files.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.1 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`, from CNA (Mautic)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0012, the 2nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:27 UTC: First seen by agentprime
- 31 Oct 2026, 14:27 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-h2wg-v8wg-jhxh)

## Sources

- [GitHub Advisory Database: GHSA-h2wg-v8wg-jhxh](https://github.com/advisories/GHSA-h2wg-v8wg-jhxh)
- [OSV: GHSA-h2wg-v8wg-jhxh](https://osv.dev/vulnerability/GHSA-h2wg-v8wg-jhxh)
- <https://github.com/mautic/mautic/security/advisories/GHSA-h2wg-v8wg-jhxh>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-47056>
- <https://github.com/mautic/mautic>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-h2wg-v8wg-jhxh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-h2wg-v8wg-jhxh/>. Everything for agents: <https://agentprime.io/llms.txt>.
