# figma-developer-mcp vulnerable to command injection in get_figma_data tool

Advisory record · `GHSA-gxw4-4fc5-9gr5`

- **Identifiers:** `GHSA-gxw4-4fc5-9gr5` · `CVE-2025-15061` · `CVE-2025-53967`
- **State:** Confirmed
- **Severity:** CVSS 8.0 High
- **Critical:** No
- **Weakness (CWE):** [CWE-77](https://cwe.mitre.org/data/definitions/77.html) · [CWE-78](https://cwe.mitre.org/data/definitions/78.html) · [CWE-420](https://cwe.mitre.org/data/definitions/420.html)
- **Tags:** [Command injection](https://agentprime.io/advisories/tag/command-injection.md) · [CWE-420](https://agentprime.io/advisories/tag/cwe-420.md)
- **Published:** 30 Sept 2025
- **Updated:** 8 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Sept 2025, 17:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `figma-developer-mcp` (npm): affected `<0.6.3`; fixed in `0.6.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The figma-developer-mcp npm package, versions before 0.6.3, has a command injection flaw in its get_figma_data tool, where user input is passed unsanitized into a child_process.exec shell command. The source describes an attacker who can get an MCP client to call the tool with crafted input, for example through indirect prompt injection, which could lead to arbitrary commands running with the server process's privileges. Upgrade to figma-developer-mcp version 0.6.3 or later, which the source says includes input validation and avoids the vulnerable call.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.0 High, CVSS 3.1: `CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N`, from CNA (mitre)

- **CISA KEV:** Not listed.
- **EPSS:** 0.061, the 93rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gxw4-4fc5-9gr5)

## Sources

- [GitHub Advisory Database: GHSA-gxw4-4fc5-9gr5](https://github.com/advisories/GHSA-gxw4-4fc5-9gr5)
- [OSV: GHSA-gxw4-4fc5-9gr5](https://osv.dev/vulnerability/GHSA-gxw4-4fc5-9gr5)
- <https://github.com/GLips/Figma-Context-MCP/security/advisories/GHSA-gxw4-4fc5-9gr5>
- <https://github.com/GLips/Figma-Context-MCP/commit/7f4b5859454b0567c2121ff22c69a0344680b124>
- <https://github.com/GLips/Figma-Context-MCP>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gxw4-4fc5-9gr5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gxw4-4fc5-9gr5/>. Everything for agents: <https://agentprime.io/llms.txt>.
