# CarrierWave Content-Type allowlist bypass vulnerability, possibly leading to XSS

Advisory record · `GHSA-gxhx-g4fq-49hj`

- **Identifiers:** `GHSA-gxhx-g4fq-49hj` · `CVE-2023-49090`
- **State:** Confirmed
- **Severity:** CVSS 6.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 29 Nov 2023
- **Updated:** 29 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Nov 2023, 21:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `carrierwave` (RubyGems): affected `>=3.0.0, <3.0.5 || <2.2.5`; fixed in `3.0.5`, `2.2.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0061, the 49th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 29 Nov 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-gxhx-g4fq-49hj](https://github.com/advisories/GHSA-gxhx-g4fq-49hj)
- [OSV: GHSA-gxhx-g4fq-49hj](https://osv.dev/vulnerability/GHSA-gxhx-g4fq-49hj)
- <https://github.com/carrierwaveuploader/carrierwave/security/advisories/GHSA-gxhx-g4fq-49hj>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-49090>
- <https://github.com/carrierwaveuploader/carrierwave/commit/39b282db5c1303899b3d3381ce8a837840f983b5>
- <https://github.com/carrierwaveuploader/carrierwave/commit/863d425c76eba12c3294227b39018f6b2dccbbf3>
- <https://github.com/carrierwaveuploader/carrierwave>
- <https://github.com/carrierwaveuploader/carrierwave/blob/master/lib/carrierwave/uploader/content_type_allowlist.rb>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/carrierwave/CVE-2023-49090.yml>
- <https://rubygems.org/gems/carrierwave/versions/2.2.5>
- <https://rubygems.org/gems/carrierwave/versions/3.0.5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gxhx-g4fq-49hj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gxhx-g4fq-49hj/>. Everything for agents: <https://agentprime.io/llms.txt>.
