# smart_proxy_dynflow gem authentication bypass in Foreman remote execution feature

Advisory record · `GHSA-gx5g-xcxj-cx2w`

- **Identifiers:** `GHSA-gx5g-xcxj-cx2w` · `CVE-2018-14643`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-287](https://cwe.mitre.org/data/definitions/287.html) · [CWE-592](https://cwe.mitre.org/data/definitions/592.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-592](https://agentprime.io/advisories/tag/cwe-592.md)
- **Published:** 8 Oct 2018
- **Updated:** 16 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Oct 2018, 23:18 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `smart_proxy_dynflow` (RubyGems): affected `>=0.2.0, <0.2.1 || <0.1.11`; fixed in `0.2.1`, `0.1.11`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (redhat)

- **CISA KEV:** Not listed.
- **EPSS:** 0.062, the 93rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 8 Oct 2018. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-gx5g-xcxj-cx2w](https://github.com/advisories/GHSA-gx5g-xcxj-cx2w)
- [OSV: GHSA-gx5g-xcxj-cx2w](https://osv.dev/vulnerability/GHSA-gx5g-xcxj-cx2w)
- <https://nvd.nist.gov/vuln/detail/CVE-2018-14643>
- <https://github.com/theforeman/smart_proxy_dynflow/pull/54>
- <https://access.redhat.com/errata/RHSA-2018:2733>
- <https://access.redhat.com/security/cve/CVE-2018-14643>
- <https://bugzilla.redhat.com/show_bug.cgi?id=1629063>
- <https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14643>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/smart_proxy_dynflow/CVE-2018-14643.yml>
- <https://github.com/theforeman/smart_proxy_dynflow>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gx5g-xcxj-cx2w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gx5g-xcxj-cx2w/>. Everything for agents: <https://agentprime.io/llms.txt>.
