# thorsten/phpmyfaq vulnerable to business logic errors

Advisory record · `GHSA-gx43-fqrx-6fcw`

- **Identifiers:** `GHSA-gx43-fqrx-6fcw` · `CVE-2023-1887` · `PKSA-w163-ccsb-gq3p`
- **State:** Confirmed
- **Severity:** CVSS 8.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-840](https://cwe.mitre.org/data/definitions/840.html)
- **Tags:** [CWE-840](https://agentprime.io/advisories/tag/cwe-840.md)
- **Published:** 5 Apr 2023
- **Updated:** 30 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Apr 2023, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `thorsten/phpmyfaq` (Packagist): affected `<3.1.12`; fixed in `3.1.12`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> phpMyFAQ (thorsten/phpmyfaq) versions before 3.1.12 have a business logic flaw that lets users with edit-only permissions add and delete categories and add FAQs, which they should not be able to do. The source does not state what access an attacker needs beyond an edit-only account. Upgrade to version 3.1.12, which fixes the issue.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.3 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:H`, from CNA (@huntrdev)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0070, the 53rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:28 UTC: First seen by agentprime
- 31 Oct 2026, 14:28 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gx43-fqrx-6fcw)

## Sources

- [GitHub Advisory Database: GHSA-gx43-fqrx-6fcw](https://github.com/advisories/GHSA-gx43-fqrx-6fcw)
- [OSV: GHSA-gx43-fqrx-6fcw](https://osv.dev/vulnerability/GHSA-gx43-fqrx-6fcw)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-1887>
- <https://github.com/thorsten/phpmyfaq/commit/400d9cd988d3287515c56b2ad6343026966f1a89>
- <https://github.com/thorsten/phpMyFAQ>
- <https://huntr.dev/bounties/e4a58835-96b5-412c-a17e-3ceed30231e1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gx43-fqrx-6fcw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gx43-fqrx-6fcw/>. Everything for agents: <https://agentprime.io/llms.txt>.
