# Pallets Werkzeug Insufficient Entropy

Advisory record · `GHSA-gq9m-qvpx-68hc`

- **Identifiers:** `GHSA-gq9m-qvpx-68hc` · `CVE-2019-14806` · `PYSEC-2019-140`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-331](https://cwe.mitre.org/data/definitions/331.html)
- **Tags:** [CWE-331](https://agentprime.io/advisories/tag/cwe-331.md)
- **Published:** 21 Aug 2019
- **Updated:** 19 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Aug 2019, 16:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `werkzeug` (PyPI): affected `<0.15.3`; fixed in `0.15.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.019, the 79th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 21 Aug 2019. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-gq9m-qvpx-68hc](https://github.com/advisories/GHSA-gq9m-qvpx-68hc)
- [OSV: GHSA-gq9m-qvpx-68hc](https://osv.dev/vulnerability/GHSA-gq9m-qvpx-68hc)
- <https://nvd.nist.gov/vuln/detail/CVE-2019-14806>
- <https://github.com/pallets/werkzeug/commit/00bc43b1672e662e5e3b8cecd79e67fc968fa246>
- <https://github.com/pallets/werkzeug>
- <https://github.com/pallets/werkzeug/blob/7fef41b120327d3912fbe12fb64f1951496fcf3e/src/werkzeug/debug/__init__.py#L168>
- <https://github.com/pypa/advisory-database/tree/main/vulns/werkzeug/PYSEC-2019-140.yaml>
- <https://palletsprojects.com/blog/werkzeug-0-15-3-released>
- <http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00034.html>
- <http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00047.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gq9m-qvpx-68hc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gq9m-qvpx-68hc/>. Everything for agents: <https://agentprime.io/llms.txt>.
