# Apache Syncope has an Improper Isolation or Compartmentalization vulnerability

Advisory record · `GHSA-gq7g-vg2q-jvq3`

- **Identifiers:** `GHSA-gq7g-vg2q-jvq3` · `CVE-2026-42782`
- **State:** Confirmed
- **Severity:** CVSS 7.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-653](https://cwe.mitre.org/data/definitions/653.html)
- **Tags:** [CWE-653](https://agentprime.io/advisories/tag/cwe-653.md)
- **Published:** 26 May 2026
- **Updated:** 30 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 May 2026, 13:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.syncope.core:syncope-core-spring` (Maven): affected `>=3.0.0-M0, <=3.0.16 || >=4.0.0-M0, <4.0.6 || >=4.1.0-M0, <4.1.1`; fixed in `4.0.6`, `4.1.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Syncope core (syncope-core-spring) versions 3.0.0 through 3.0.16, 4.0.0 through 4.0.5, and 4.1.0 are affected. An administrator with entitlements for Implementations can create a Groovy class whose static initializer runs untrusted code outside the sandbox. Upgrade to 4.0.6 or 4.1.1, which force the static initializer to run in the sandbox.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.2 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0065, the 51st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:20 UTC: First seen by agentprime
- 31 Oct 2026, 14:20 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gq7g-vg2q-jvq3)

## Sources

- [GitHub Advisory Database: GHSA-gq7g-vg2q-jvq3](https://github.com/advisories/GHSA-gq7g-vg2q-jvq3)
- [OSV: GHSA-gq7g-vg2q-jvq3](https://osv.dev/vulnerability/GHSA-gq7g-vg2q-jvq3)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-42782>
- <https://lists.apache.org/thread/b869ms0ofrd129f7tgsn9flxgv9ztg2r>
- <http://www.openwall.com/lists/oss-security/2026/05/25/4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gq7g-vg2q-jvq3>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gq7g-vg2q-jvq3/>. Everything for agents: <https://agentprime.io/llms.txt>.
