# vLLM DeepSeek-OCR image processing vulnerable to denial of service

Advisory record · `GHSA-gq5q-89c7-vhvx`

- **Identifiers:** `GHSA-gq5q-89c7-vhvx` · `CVE-2026-115914`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-617](https://cwe.mitre.org/data/definitions/617.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Oct 2026, 21:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `>=0.11.1, <0.32.0`; fixed in `0.32.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> vLLM versions from 0.11.1 before 0.32.0 that serve DeepSeek-OCR family models (DeepSeek-OCR, DeepSeek-OCR-2, or Unlimited-OCR) can be crashed by one unauthenticated chat request containing an image with a specific pixel distribution, under default configuration. The crash takes down the serving process, and the deployment stays down until it is manually restarted. Upgrade vLLM to 0.32.0 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0040, the 34th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gq5q-89c7-vhvx)

## Sources

- [GitHub Advisory Database: GHSA-gq5q-89c7-vhvx](https://github.com/advisories/GHSA-gq5q-89c7-vhvx)
- [OSV: GHSA-gq5q-89c7-vhvx](https://osv.dev/vulnerability/GHSA-gq5q-89c7-vhvx)
- <https://github.com/vllm-project/vllm/security/advisories/GHSA-gq5q-89c7-vhvx>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-115914>
- <https://github.com/vllm-project/vllm/pull/59417>
- <https://github.com/vllm-project/vllm/commit/c15672cfb49152ebf65cfd188e71b84593ec5686>
- <https://github.com/vllm-project/vllm>
- <https://github.com/vllm-project/vllm/releases/tag/v0.32.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gq5q-89c7-vhvx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gq5q-89c7-vhvx/>. Everything for agents: <https://agentprime.io/llms.txt>.
