# MLflow Use of Default Password Authentication Bypass Vulnerability

Advisory record · `GHSA-gq3w-7jj3-x7gr`

- **Identifiers:** `GHSA-gq3w-7jj3-x7gr` · `CVE-2026-2635` · `PYSEC-2026-421`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-798](https://cwe.mitre.org/data/definitions/798.html) · [CWE-1393](https://cwe.mitre.org/data/definitions/1393.html)
- **Tags:** [Hard-coded credentials](https://agentprime.io/advisories/tag/hard-coded-credentials.md) · [CWE-1393](https://agentprime.io/advisories/tag/cwe-1393.md)
- **Published:** 21 Feb 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Feb 2026, 00:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `mlflow` (PyPI): affected `<3.8.0rc0`; fixed in `3.8.0rc0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> MLflow versions before 3.8.0rc0 are affected. The MLflow authentication configuration ships with hard-coded default credentials, so a remote attacker with no prior access can bypass authentication and run arbitrary code in the context of the administrator. Upgrade to MLflow 3.8.0rc0 or later; the source lists no workaround.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (zdi)

- **CISA KEV:** Not listed.
- **EPSS:** 0.011, the 65th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:34 UTC: First seen by agentprime
- 31 Oct 2026, 14:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gq3w-7jj3-x7gr)

## Sources

- [GitHub Advisory Database: GHSA-gq3w-7jj3-x7gr](https://github.com/advisories/GHSA-gq3w-7jj3-x7gr)
- [OSV: GHSA-gq3w-7jj3-x7gr](https://osv.dev/vulnerability/GHSA-gq3w-7jj3-x7gr)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-2635>
- <https://github.com/mlflow/mlflow/pull/19260>
- <https://github.com/mlflow/mlflow/commit/5bf2ec2bd4222a18d78631183ac7f6b752afe8a4>
- <https://github.com/mlflow/mlflow>
- <https://github.com/mlflow/mlflow/releases/tag/v3.8.0rc0>
- <https://www.zerodayinitiative.com/advisories/ZDI-26-111>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gq3w-7jj3-x7gr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gq3w-7jj3-x7gr/>. Everything for agents: <https://agentprime.io/llms.txt>.
