# CGI has Denial of Service (DoS) potential in Cookie.parse

Advisory record · `GHSA-gh9q-2xrm-x6qv`

- **Identifiers:** `GHSA-gh9q-2xrm-x6qv` · `CVE-2025-27219`
- **State:** Confirmed
- **Severity:** CVSS 5.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 3 Mar 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Mar 2025, 20:53 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `cgi` (RubyGems): affected `<0.3.5.1 || >=0.3.6, <0.3.7 || >=0.4.0, <0.4.2`; fixed in `0.3.5.1`, `0.3.7`, `0.4.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L`, from CNA (mitre)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0085, the 58th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gh9q-2xrm-x6qv)

## Sources

- [GitHub Advisory Database: GHSA-gh9q-2xrm-x6qv](https://github.com/advisories/GHSA-gh9q-2xrm-x6qv)
- [OSV: GHSA-gh9q-2xrm-x6qv](https://osv.dev/vulnerability/GHSA-gh9q-2xrm-x6qv)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-27219>
- <https://github.com/ruby/cgi/pull/52>
- <https://github.com/ruby/cgi/pull/53>
- <https://github.com/ruby/cgi/pull/54>
- <https://hackerone.com/reports/2936778>
- <https://github.com/ruby/cgi>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/cgi/CVE-2025-27219.yml>
- <https://lists.debian.org/debian-lts-announce/2025/03/msg00008.html>
- <https://www.cve.org/CVERecord?id=CVE-2025-27219>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gh9q-2xrm-x6qv>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gh9q-2xrm-x6qv/>. Everything for agents: <https://agentprime.io/llms.txt>.
