# Next.js: HTTP request smuggling in rewrites

Advisory record · `GHSA-ggv3-7p47-pfv8`

- **Identifiers:** `GHSA-ggv3-7p47-pfv8` · `CVE-2026-29057`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 17 Mar 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Mar 2026, 16:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `next` (npm): affected `>=16.0.0-beta.0, <16.1.7 || >=9.5.0, <15.5.13`; fixed in `16.1.7`, `15.5.13`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0046, the 40th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 17 Mar 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-ggv3-7p47-pfv8](https://github.com/advisories/GHSA-ggv3-7p47-pfv8)
- [OSV: GHSA-ggv3-7p47-pfv8](https://osv.dev/vulnerability/GHSA-ggv3-7p47-pfv8)
- <https://github.com/vercel/next.js/security/advisories/GHSA-ggv3-7p47-pfv8>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-29057>
- <https://github.com/vercel/next.js/commit/dc98c04f376c6a1df76ec3e0a2d07edf4abdabd6>
- <https://github.com/vercel/next.js>
- <https://github.com/vercel/next.js/releases/tag/v15.5.13>
- <https://github.com/vercel/next.js/releases/tag/v16.1.7>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-ggv3-7p47-pfv8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-ggv3-7p47-pfv8/>. Everything for agents: <https://agentprime.io/llms.txt>.
