# Spring Web Services: Wss4jSecurityInterceptor disables WS-I BSP validation by default

Advisory record · `GHSA-gg9r-wr4p-w63h`

- **Identifiers:** `GHSA-gg9r-wr4p-w63h` · `CVE-2026-40994`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1188](https://cwe.mitre.org/data/definitions/1188.html)
- **Tags:** [CWE-1188](https://agentprime.io/advisories/tag/cwe-1188.md)
- **Published:** 11 Jun 2026
- **Updated:** 21 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 Jun 2026, 09:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.springframework.ws:spring-ws-security` (Maven): affected `>=5.0.0, <5.0.2 || >=4.1.0, <4.1.4 || >=4.0.0, <=4.0.18 || >=3.1.0, <=3.1.8`; fixed in `5.0.2`, `4.1.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Spring Web Services (spring-ws-security) versions 5.0.0 through 5.0.1, 4.1.0 through 4.1.3, 4.0.0 through 4.0.18, and 3.1.0 through 3.1.8 disable WS-I Basic Security Profile enforcement in Wss4jSecurityInterceptor by default, so inbound messages that violate BSP rules can be accepted. The source gives few details on the exact attack. Upgrade spring-ws-security to 5.0.2 or 4.1.4, or to a later release in the same line.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`, from CNA (vmware)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0023, the 13th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gg9r-wr4p-w63h)

## Sources

- [GitHub Advisory Database: GHSA-gg9r-wr4p-w63h](https://github.com/advisories/GHSA-gg9r-wr4p-w63h)
- [OSV: GHSA-gg9r-wr4p-w63h](https://osv.dev/vulnerability/GHSA-gg9r-wr4p-w63h)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-40994>
- <https://github.com/spring-projects/spring-ws>
- <https://spring.io/security/cve-2026-40994>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gg9r-wr4p-w63h>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gg9r-wr4p-w63h/>. Everything for agents: <https://agentprime.io/llms.txt>.
