# SmallRye Fault Tolerance out-of-memory (OOM) issue

Advisory record · `GHSA-gfh6-3pqw-x2j4`

- **Identifiers:** `GHSA-gfh6-3pqw-x2j4` · `CVE-2025-2240`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1325](https://cwe.mitre.org/data/definitions/1325.html)
- **Tags:** [CWE-1325](https://agentprime.io/advisories/tag/cwe-1325.md)
- **Published:** 12 Mar 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Mar 2025, 15:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.smallrye:smallrye-fault-tolerance-core` (Maven): affected `>=6.3.0, <6.4.2 || >=6.5.0, <6.9.0`; fixed in `6.4.2`, `6.9.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> SmallRye Fault Tolerance (io.smallrye:smallrye-fault-tolerance-core) versions 6.3.0 up to but not including 6.4.2, and 6.5.0 up to but not including 6.9.0, are affected. An attacker who can send requests to the metrics URI can trigger repeated creation of new objects in a map, exhausting memory and causing a denial of service. Upgrade to version 6.4.2 or 6.9.0, depending on your release line.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (redhat)

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 69th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 12 Mar 2025, 14:55 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2025-2240)
- 12 Mar 2025, 15:15 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2025-2240)
- 31 Oct 2026, 14:18 UTC: First seen by agentprime
- 31 Oct 2026, 14:18 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gfh6-3pqw-x2j4)

## Sources

- [GitHub Advisory Database: GHSA-gfh6-3pqw-x2j4](https://github.com/advisories/GHSA-gfh6-3pqw-x2j4)
- [OSV: GHSA-gfh6-3pqw-x2j4](https://osv.dev/vulnerability/GHSA-gfh6-3pqw-x2j4)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-2240>
- <https://github.com/smallrye/smallrye-fault-tolerance/pull/985>
- <https://github.com/smallrye/smallrye-fault-tolerance/pull/985/files#diff-88c4a089e0cb88e4bdf285490e2617c29b9979a778e33957e4448260e286b91aR299>
- <https://github.com/smallrye/smallrye-fault-tolerance/commit/e8bcad3d5e8bbac0a3219bd5c13661adf6ed6bbb>
- <https://access.redhat.com/errata/RHSA-2025:3376>
- <https://access.redhat.com/errata/RHSA-2025:3541>
- <https://access.redhat.com/errata/RHSA-2025:3543>
- <https://access.redhat.com/security/cve/CVE-2025-2240>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2351452>
- <https://github.com/smallrye/smallrye-fault-tolerance>
- <https://smallrye.io/blog/fault-tolerance-6-9-0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gfh6-3pqw-x2j4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gfh6-3pqw-x2j4/>. Everything for agents: <https://agentprime.io/llms.txt>.
