# OpenAM: WebAuthn Java deserialization RCE via ObjectInputFilter depth>1 bypass

Advisory record · `GHSA-gf8h-gq53-288j`

- **Identifiers:** `GHSA-gf8h-gq53-288j` · `CVE-2026-62263`
- **State:** Confirmed
- **Severity:** CVSS 9.2 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-502](https://cwe.mitre.org/data/definitions/502.html)
- **Tags:** [Insecure deserialization](https://agentprime.io/advisories/tag/deserialization.md)
- **Published:** 24 Jul 2026
- **Updated:** 24 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Jul 2026, 21:08 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.2: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.openidentityplatform.openam:openam-auth-webauthn` (Maven): affected `<16.1.2`; fixed in `16.1.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of openam-auth-webauthn before 16.1.2 in the Maven package org.openidentityplatform.openam:openam-auth-webauthn are affected. An unauthenticated remote attacker can send a crafted serialized object that runs arbitrary code during deserialization, provided a suitable gadget class is on the classpath. Upgrade to version 16.1.2, which fixes the issue.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.2 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0086, the 58th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gf8h-gq53-288j)

## Sources

- [GitHub Advisory Database: GHSA-gf8h-gq53-288j](https://github.com/advisories/GHSA-gf8h-gq53-288j)
- [OSV: GHSA-gf8h-gq53-288j](https://osv.dev/vulnerability/GHSA-gf8h-gq53-288j)
- <https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-gf8h-gq53-288j>
- <https://github.com/OpenIdentityPlatform/OpenAM/commit/9dd0fbe07f70f118cf45042d3a9ffb32f3c21e08>
- <https://github.com/OpenIdentityPlatform/OpenAM>
- <https://github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gf8h-gq53-288j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gf8h-gq53-288j/>. Everything for agents: <https://agentprime.io/llms.txt>.
