# Crash caused by integer conversion to unsigned

Advisory record · `GHSA-gf88-j2mg-cc82`

- **Identifiers:** `GHSA-gf88-j2mg-cc82` · `BIT-tensorflow-2021-37661` · `CVE-2021-37661` · `PYSEC-2021-283` · `PYSEC-2021-574` · `PYSEC-2021-772`
- **State:** Confirmed
- **Severity:** CVSS 5.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-681](https://cwe.mitre.org/data/definitions/681.html)
- **Tags:** [CWE-681](https://agentprime.io/advisories/tag/cwe-681.md)
- **Published:** 25 Aug 2021
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 25 Aug 2021, 14:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `tensorflow` (PyPI): affected `<2.3.4 || >=2.4.0, <2.4.3 || >=2.5.0, <2.5.1`; fixed in `2.3.4`, `2.4.3`, `2.5.1`
- `tensorflow-cpu` (PyPI): affected `<2.3.4 || >=2.4.0, <2.4.3 || >=2.5.0, <2.5.1`; fixed in `2.3.4`, `2.4.3`, `2.5.1`
- `tensorflow-gpu` (PyPI): affected `<2.3.4 || >=2.4.0, <2.4.3 || >=2.5.0, <2.5.1`; fixed in `2.3.4`, `2.4.3`, `2.5.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.5 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0015, the 4th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 25 Aug 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-gf88-j2mg-cc82](https://github.com/advisories/GHSA-gf88-j2mg-cc82)
- [OSV: GHSA-gf88-j2mg-cc82](https://osv.dev/vulnerability/GHSA-gf88-j2mg-cc82)
- <https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gf88-j2mg-cc82>
- <https://nvd.nist.gov/vuln/detail/CVE-2021-37661>
- <https://github.com/tensorflow/tensorflow/commit/8a84f7a2b5a2b27ecf88d25bad9ac777cd2f7992>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-574.yaml>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-772.yaml>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-283.yaml>
- <https://github.com/tensorflow/tensorflow>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gf88-j2mg-cc82>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gf88-j2mg-cc82/>. Everything for agents: <https://agentprime.io/llms.txt>.
