# Apache Tomcat has an Improper Access Control, Incorrect Authorization vulnerability

Advisory record · `GHSA-gcx9-497g-6cp6`

- **Identifiers:** `GHSA-gcx9-497g-6cp6` · `BIT-tomcat-2026-65182` · `CVE-2026-65182`
- **State:** Confirmed
- **Severity:** CVSS 9.1 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-284](https://cwe.mitre.org/data/definitions/284.html) · [CWE-863](https://cwe.mitre.org/data/definitions/863.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 26 Aug 2026
- **Updated:** 11 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Aug 2026, 00:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.1: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.apache.tomcat:tomcat` (Maven): affected `>=11.0.0-M1, <11.0.25 || >=10.1.0-M1, <10.1.58 || >=9.0.0-M1, <9.0.121 || >=8.5.0, <=8.5.100 || >=7.0.0, <=7.0.109`; fixed in `11.0.25`, `10.1.58`, `9.0.121`
- `org.apache.tomcat:tomcat-catalina` (Maven): affected `>=11.0.0-M1, <11.0.25 || >=10.1.0-M1, <10.1.58 || >=9.0.0-M1, <9.0.121 || >=8.5.0, <=8.5.100 || >=7.0.0, <=7.0.109`; fixed in `11.0.25`, `10.1.58`, `9.0.121`
- `org.apache.tomcat.embed:tomcat-embed-core` (Maven): affected `>=11.0.0-M1, <11.0.25 || >=10.1.0-M1, <10.1.58 || >=9.0.0-M1, <9.0.121 || >=8.5.0, <=8.5.100 || >=7.0.0, <=7.0.109`; fixed in `11.0.25`, `10.1.58`, `9.0.121`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Tomcat versions 11.0.0-M1 through 11.0.24, 10.1.0-M1 through 10.1.57, 9.0.0.M1 through 9.0.120, 8.5.0 through 8.5.100, and 7.0.0 through 7.0.109 are affected, along with the tomcat, tomcat-catalina and tomcat-embed-core Maven packages. When a constraint on a longer path is configured before a more restrictive constraint on a shorter sub-path, the source says the security constraint can be bypassed. The source does not describe the attacker's required access level. Upgrade to 11.0.25, 10.1.58, or 9.0.121, which fix the issue; no fix is listed for 8.5.x or 7.0.x.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.1 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0065, the 51st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gcx9-497g-6cp6)

## Sources

- [GitHub Advisory Database: GHSA-gcx9-497g-6cp6](https://github.com/advisories/GHSA-gcx9-497g-6cp6)
- [OSV: GHSA-gcx9-497g-6cp6](https://osv.dev/vulnerability/GHSA-gcx9-497g-6cp6)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-65182>
- <https://github.com/apache/tomcat/commit/8bafd79a3b54684e80e9cb1bafd4746aede7d3f5>
- <https://github.com/apache/tomcat/commit/b2c56ec8f20c66773a1a813034ffcdb60841f1cf>
- <https://github.com/apache/tomcat/commit/b79752d2a8578d94743e2a95c50af297f780c0df>
- <https://lists.apache.org/thread/joosxvzc9b49ttj8lj0jw9mqt0ml767m>
- <https://tomcat.apache.org/security-10.html>
- <https://tomcat.apache.org/security-11.html>
- <https://tomcat.apache.org/security-9.html>
- <http://www.openwall.com/lists/oss-security/2026/08/26/1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gcx9-497g-6cp6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gcx9-497g-6cp6/>. Everything for agents: <https://agentprime.io/llms.txt>.
