# docx4j: Stack Overflow via Cyclic \`w:basedOn\` Style Chain leads to Denial of Service

Advisory record · `GHSA-gc95-3vw8-vg43`

- **Identifiers:** `GHSA-gc95-3vw8-vg43` · `CVE-2026-53752`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-674](https://cwe.mitre.org/data/definitions/674.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Aug 2026, 21:55 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.docx4j:docx4j-core` (Maven): affected `<11.5.14`; fixed in `11.5.14`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> docx4j-core (Maven org.docx4j:docx4j-core) versions before 11.5.14 are vulnerable to a stack overflow caused by cyclic style inheritance: a Word document whose styles reference each other in a loop through the basedOn chain triggers unbounded recursion during style resolution. An attacker who can get a crafted DOCX processed by the application, for example by uploading it, can crash the processing thread, which is a denial of service. Upgrade to docx4j-core 11.5.14 or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0063, the 50th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-gc95-3vw8-vg43)

## Sources

- [GitHub Advisory Database: GHSA-gc95-3vw8-vg43](https://github.com/advisories/GHSA-gc95-3vw8-vg43)
- [OSV: GHSA-gc95-3vw8-vg43](https://osv.dev/vulnerability/GHSA-gc95-3vw8-vg43)
- <https://github.com/plutext/docx4j/security/advisories/GHSA-gc95-3vw8-vg43>
- <https://github.com/plutext/docx4j>
- <https://github.com/plutext/docx4j/releases/tag/docx4j-11.5.14>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-gc95-3vw8-vg43>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-gc95-3vw8-vg43/>. Everything for agents: <https://agentprime.io/llms.txt>.
