# Moodle does not revoke role capabilities correctly

Advisory record · `GHSA-g9m2-c2x5-fr2v`

- **Identifiers:** `GHSA-g9m2-c2x5-fr2v` · `CVE-2019-14879` · `PKSA-tsyk-q1km-44v1`
- **State:** Confirmed
- **Severity:** CVSS 4.2 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-264](https://cwe.mitre.org/data/definitions/264.html) · [CWE-273](https://cwe.mitre.org/data/definitions/273.html)
- **Tags:** [CWE-264](https://agentprime.io/advisories/tag/cwe-264.md) · [CWE-273](https://agentprime.io/advisories/tag/cwe-273.md)
- **Published:** 24 May 2022
- **Updated:** 16 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 May 2022, 17:05 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `moodle/moodle` (Packagist): affected `>=3.7.0, <3.7.3 || >=3.6.0, <3.6.7 || >=3.5.0, <3.5.9`; fixed in `3.7.3`, `3.6.7`, `3.5.9`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Moodle versions 3.5.0 before 3.5.9, 3.6.0 before 3.6.7, and 3.7.0 before 3.7.3 do not revoke role capabilities correctly. When a cohort role assignment was removed, the associated capabilities were not always revoked, so a user could keep permissions they should have lost. The source gives few details on who can exploit this or how. Upgrade to Moodle 3.5.9, 3.6.7, 3.7.3, or later.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.2 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`, from CNA (redhat)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0071, the 53rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:31 UTC: First seen by agentprime
- 31 Oct 2026, 14:31 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g9m2-c2x5-fr2v)

## Sources

- [GitHub Advisory Database: GHSA-g9m2-c2x5-fr2v](https://github.com/advisories/GHSA-g9m2-c2x5-fr2v)
- [OSV: GHSA-g9m2-c2x5-fr2v](https://osv.dev/vulnerability/GHSA-g9m2-c2x5-fr2v)
- <https://nvd.nist.gov/vuln/detail/CVE-2019-14879>
- <https://github.com/moodle/moodle/commit/7b5f4a62c18fd5bad6956828aade23e1f15b4be3>
- <https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14879>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g9m2-c2x5-fr2v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g9m2-c2x5-fr2v/>. Everything for agents: <https://agentprime.io/llms.txt>.
