# Trix has a stored XSS vulnerability through its attachment attribute

Advisory record · `GHSA-g9jg-w8vm-g96v`

- **Identifiers:** `GHSA-g9jg-w8vm-g96v`
- **State:** Confirmed
- **Severity:** CVSS 4.6 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 31 Dec 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 31 Dec 2025, 22:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `trix` (npm): affected `<2.1.16`; fixed in `2.1.16`
- `action_text-trix` (RubyGems): affected `<2.1.16`; fixed in `2.1.16`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.6 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 31 Dec 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-g9jg-w8vm-g96v](https://github.com/advisories/GHSA-g9jg-w8vm-g96v)
- [OSV: GHSA-g9jg-w8vm-g96v](https://osv.dev/vulnerability/GHSA-g9jg-w8vm-g96v)
- <https://github.com/basecamp/trix/security/advisories/GHSA-g9jg-w8vm-g96v>
- <https://github.com/basecamp/trix/commit/73c20cf03ab2b56c0ef9c9b1aaf63f2de44f4010>
- <https://github.com/basecamp/trix>
- <https://github.com/basecamp/trix/releases/tag/v2.1.16>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/action_text-trix/GHSA-g9jg-w8vm-g96v.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g9jg-w8vm-g96v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g9jg-w8vm-g96v/>. Everything for agents: <https://agentprime.io/llms.txt>.
