# Symfony Vulnerable to Timing Attack

Advisory record · `GHSA-g97c-jfx6-xvxh`

- **Identifiers:** `GHSA-g97c-jfx6-xvxh` · `CVE-2015-8125` · `PKSA-5979-1yv4-cw4f` · `PKSA-krbp-gnkk-54bj` · `PKSA-vjxr-btnx-3nkm` · `PKSA-x6by-dh6n-pzrc`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-208](https://cwe.mitre.org/data/definitions/208.html)
- **Tags:** [CWE-208](https://agentprime.io/advisories/tag/cwe-208.md)
- **Published:** 17 May 2022
- **Updated:** 30 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 May 2022, 03:25 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `symfony/symfony` (Packagist): affected `>=2.3.0, <2.3.35 || >=2.7.0, <2.7.7 || >=2.4.0, <2.6.12`; fixed in `2.3.35`, `2.7.7`, `2.6.12`
- `symfony/form` (Packagist): affected `>=2.3.0, <2.3.35 || >=2.4.0, <2.6.12 || >=2.7.0, <2.7.7`; fixed in `2.3.35`, `2.6.12`, `2.7.7`
- `symfony/security-http` (Packagist): affected `>=2.4.0, <2.6.12 || >=2.7.0, <2.7.7`; fixed in `2.6.12`, `2.7.7`
- `symfony/security` (Packagist): affected `>=2.3.0, <2.3.35 || >=2.4.0, <2.6.12 || >=2.7.0, <2.7.7`; fixed in `2.3.35`, `2.6.12`, `2.7.7`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Symfony's symfony/symfony, symfony/form, symfony/security and symfony/security-http packages are affected in versions 2.3.0 before 2.3.35, 2.4.0 before 2.6.12, and 2.7.0 before 2.7.7 (security-http is affected only from 2.4.0). A remote attacker may be able to carry out a timing attack against remember-me, digest authentication, or legacy CSRF token checks, with unspecified impact. The source gives few details. Upgrade to 2.3.35, 2.6.12, or 2.7.7, depending on your branch.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.025, the 85th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:28 UTC: First seen by agentprime
- 31 Oct 2026, 14:28 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g97c-jfx6-xvxh)

## Sources

- [GitHub Advisory Database: GHSA-g97c-jfx6-xvxh](https://github.com/advisories/GHSA-g97c-jfx6-xvxh)
- [OSV: GHSA-g97c-jfx6-xvxh](https://osv.dev/vulnerability/GHSA-g97c-jfx6-xvxh)
- <https://nvd.nist.gov/vuln/detail/CVE-2015-8125>
- <https://github.com/symfony/symfony/pull/16630>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/form/CVE-2015-8125.yaml>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-http/CVE-2015-8125.yaml>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security/CVE-2015-8125.yaml>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2015-8125.yaml>
- <https://symfony.com/blog/cve-2015-8125-potential-remote-timing-attack-vulnerability-in-security-remember-me-service>
- <https://symfony.com/cve-2015-8125>
- <https://web.archive.org/web/20200228050051/http://www.securityfocus.com/bid/77692>
- <http://lists.fedoraproject.org/pipermail/package-announce/2015-December/173271.html>
- <http://lists.fedoraproject.org/pipermail/package-announce/2015-December/173300.html>
- <http://www.debian.org/security/2015/dsa-3402>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g97c-jfx6-xvxh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g97c-jfx6-xvxh/>. Everything for agents: <https://agentprime.io/llms.txt>.
