# Duplicate Advisory: Regular Expression Denial of Service in braces

Advisory record · `GHSA-g95f-p29q-9xw4` · Withdrawn

- **Identifiers:** `GHSA-g95f-p29q-9xw4`
- **State:** Withdrawn
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-185](https://cwe.mitre.org/data/definitions/185.html) · [CWE-400](https://cwe.mitre.org/data/definitions/400.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-185](https://agentprime.io/advisories/tag/cwe-185.md)
- **Published:** 6 Jun 2019
- **Updated:** 3 Feb 2026
- **Reviewed by a person:** No

**Withdrawn.** The GitHub Advisory Database withdrew this advisory on 3 Feb 2026. The record stays here, marked withdrawn.

Published by the GitHub Advisory Database at 6 Jun 2019, 15:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `braces` (npm): affected `<2.3.1`; fixed in `2.3.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 6 Jun 2019. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-g95f-p29q-9xw4](https://github.com/advisories/GHSA-g95f-p29q-9xw4)
- [OSV: GHSA-g95f-p29q-9xw4](https://osv.dev/vulnerability/GHSA-g95f-p29q-9xw4)
- <https://github.com/micromatch/braces/commit/abdafb0cae1e0c00f184abbadc692f4eaa98f451>
- <https://snyk.io/vuln/npm:braces:20180219>
- <https://www.npmjs.com/advisories/786>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g95f-p29q-9xw4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g95f-p29q-9xw4/>. Everything for agents: <https://agentprime.io/llms.txt>.
