# Netty: Out-of-date OCSP Responses Accepted by OcspServerCertificateValidator

Advisory record · `GHSA-g7hg-vrcf-mvmr`

- **Identifiers:** `GHSA-g7hg-vrcf-mvmr` · `CVE-2026-56821`
- **State:** Confirmed
- **Severity:** CVSS 7.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-299](https://cwe.mitre.org/data/definitions/299.html)
- **Tags:** [CWE-299](https://agentprime.io/advisories/tag/cwe-299.md)
- **Published:** 22 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Jul 2026, 21:46 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.netty:netty-handler-ssl-ocsp` (Maven): affected `>=4.2.0.Final, <4.2.16.Final || <4.1.136.Final`; fixed in `4.2.16.Final`, `4.1.136.Final`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Netty's netty-handler-ssl-ocsp package, versions from 4.2.0.Final up to but not including 4.2.16.Final, and versions before 4.1.136.Final, is affected. In OcspServerCertificateValidator, an OCSP response past its freshness window still produces a VALID result. An on-path attacker who replays a stale GOOD response can get a since-revoked certificate accepted. Upgrade to 4.2.16.Final or 4.1.136.Final. The source lists no workaround.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.4 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0022, the 12th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:17 UTC: First seen by agentprime
- 31 Oct 2026, 14:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g7hg-vrcf-mvmr)

## Sources

- [GitHub Advisory Database: GHSA-g7hg-vrcf-mvmr](https://github.com/advisories/GHSA-g7hg-vrcf-mvmr)
- [OSV: GHSA-g7hg-vrcf-mvmr](https://osv.dev/vulnerability/GHSA-g7hg-vrcf-mvmr)
- <https://github.com/netty/netty/security/advisories/GHSA-g7hg-vrcf-mvmr>
- <https://github.com/netty/netty>
- <https://github.com/netty/netty/releases/tag/netty-4.1.136.Final>
- <https://github.com/netty/netty/releases/tag/netty-4.2.16.Final>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g7hg-vrcf-mvmr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g7hg-vrcf-mvmr/>. Everything for agents: <https://agentprime.io/llms.txt>.
