# Publify contains Weak Password Requirements

Advisory record · `GHSA-g7gf-2rqw-5rwx`

- **Identifiers:** `GHSA-g7gf-2rqw-5rwx` · `BIT-publify-2023-0569` · `CVE-2023-0569`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-521](https://cwe.mitre.org/data/definitions/521.html)
- **Tags:** [Hard-coded credentials](https://agentprime.io/advisories/tag/hard-coded-credentials.md)
- **Published:** 29 Jan 2023
- **Updated:** 6 Dec 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Jan 2023, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `publify_core` (RubyGems): affected `<9.2.10`; fixed in `9.2.10`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`, from CNA (@huntrdev)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0070, the 53rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 29 Jan 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-g7gf-2rqw-5rwx](https://github.com/advisories/GHSA-g7gf-2rqw-5rwx)
- [OSV: GHSA-g7gf-2rqw-5rwx](https://osv.dev/vulnerability/GHSA-g7gf-2rqw-5rwx)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-0569>
- <https://github.com/publify/publify/commit/8905e4e639cf03b758da558568a86c9816253b2d>
- <https://github.com/publify/publify>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2023-0569.yml>
- <https://huntr.dev/bounties/81b1e1da-10dd-435e-94ae-4bdd41df6df9>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g7gf-2rqw-5rwx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g7gf-2rqw-5rwx/>. Everything for agents: <https://agentprime.io/llms.txt>.
