# Mesop: Unauthenticated ANSI Escape Sequence Injection in CSP Reporting Endpoint

Advisory record · `GHSA-g7f6-rxc4-qhph`

- **Identifiers:** `GHSA-g7f6-rxc4-qhph` · `CVE-2026-93421` · `PYSEC-2026-4105`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-117](https://cwe.mitre.org/data/definitions/117.html) · [CWE-150](https://cwe.mitre.org/data/definitions/150.html)
- **Tags:** [Other injection](https://agentprime.io/advisories/tag/injection.md) · [CWE-150](https://agentprime.io/advisories/tag/cwe-150.md)
- **Published:** 23 Sept 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Sept 2026, 19:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `mesop` (PyPI): affected `<1.3.4`; fixed in `1.3.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Mesop versions before 1.3.4 are affected. The /\_\_csp\_\_ reporting endpoint writes fields from unauthenticated JSON reports to stdout without escaping control characters. A remote attacker can send a crafted request with ANSI/VT100 escape sequences that, when logs are viewed in an ANSI-capable terminal, can clear the screen, hide text, or show misleading messages. Upgrade to Mesop 1.3.4 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0053, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:09 UTC: First seen by agentprime
- 31 Oct 2026, 14:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g7f6-rxc4-qhph)

## Sources

- [GitHub Advisory Database: GHSA-g7f6-rxc4-qhph](https://github.com/advisories/GHSA-g7f6-rxc4-qhph)
- [OSV: GHSA-g7f6-rxc4-qhph](https://osv.dev/vulnerability/GHSA-g7f6-rxc4-qhph)
- <https://github.com/mesop-dev/mesop/security/advisories/GHSA-g7f6-rxc4-qhph>
- <https://github.com/mesop-dev/mesop/pull/1397>
- <https://github.com/mesop-dev/mesop/commit/f38c42a1d3eba246941ef8d7f645072d53c58785>
- <https://github.com/mesop-dev/mesop>
- <https://github.com/mesop-dev/mesop/releases/tag/v1.3.4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g7f6-rxc4-qhph>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g7f6-rxc4-qhph/>. Everything for agents: <https://agentprime.io/llms.txt>.
