# @hulumi/policies bypasses IAM-role policy checks when the role trusts multiple OIDC providers

Advisory record · `GHSA-g759-4pxw-6692`

- **Identifiers:** `GHSA-g759-4pxw-6692` · `CVE-2026-48032`
- **State:** Confirmed
- **Severity:** CVSS 8.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-697](https://cwe.mitre.org/data/definitions/697.html)
- **Tags:** [CWE-697](https://agentprime.io/advisories/tag/cwe-697.md)
- **Published:** 10 Jun 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Jun 2026, 13:37 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@hulumi/policies` (npm): affected `<1.4.0`; fixed in `1.4.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.3 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0054, the 45th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 10 Jun 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-g759-4pxw-6692](https://github.com/advisories/GHSA-g759-4pxw-6692)
- [OSV: GHSA-g759-4pxw-6692](https://osv.dev/vulnerability/GHSA-g759-4pxw-6692)
- <https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-g759-4pxw-6692>
- <https://github.com/kerberosmansour/hulumi/pull/178>
- <https://github.com/kerberosmansour/hulumi>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g759-4pxw-6692>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g759-4pxw-6692/>. Everything for agents: <https://agentprime.io/llms.txt>.
