# Russh: Configured server auth-attempt cap is not enforced in the USERAUTH_REQUEST runtime path

Advisory record · `GHSA-g6xm-f9xp-qq35`

- **Identifiers:** `GHSA-g6xm-f9xp-qq35` · `CVE-2026-102825`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-307](https://cwe.mitre.org/data/definitions/307.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md)
- **Published:** 30 Sept 2026
- **Updated:** 30 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Sept 2026, 23:26 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `russh` (crates.io): affected `<0.62.6`; fixed in `0.62.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> russh versions before 0.62.6 do not enforce the configured max_auth_attempts limit on authentication requests. An unauthenticated remote client that can reach a russh-based SSH server can keep sending authentication requests on one connection past that limit, which increases the opportunity for online password guessing. Upgrade russh to 0.62.6.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0035, the 29th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g6xm-f9xp-qq35)

## Sources

- [GitHub Advisory Database: GHSA-g6xm-f9xp-qq35](https://github.com/advisories/GHSA-g6xm-f9xp-qq35)
- [OSV: GHSA-g6xm-f9xp-qq35](https://osv.dev/vulnerability/GHSA-g6xm-f9xp-qq35)
- <https://github.com/Eugeny/russh/security/advisories/GHSA-g6xm-f9xp-qq35>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-102825>
- <https://github.com/Eugeny/russh/commit/f8fd0b11a393364dc7f01a182482d86adafdd653>
- <https://github.com/Eugeny/russh>
- <https://github.com/Eugeny/russh/releases/tag/v0.62.6>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g6xm-f9xp-qq35>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g6xm-f9xp-qq35/>. Everything for agents: <https://agentprime.io/llms.txt>.
